Performance survey.

General discussion related to the game goes here.

Moderators: Balthagor, Legend, Moderators

rlame
Sergeant
Posts: 15
Joined: Sep 06 2018
Human: Yes

Performance survey.

Post by rlame »

Hello!

I'm interested on how this game run on different setups.
So please download linked savegame (7-zipped or .sav) and
post how many seconds it took for you to run one day and total of 10 days from beginning of save and what cpu and ram you have.

My setup Ryzen 2700x 16gb ddr4 3333mhz.
Cpu boost in test was 4100mhz.


Example:
First day time 16,5s.
From start of save to sept 6th (10 days) 2min 26s = 14,6s / day average.

zipped
https://drive.google.com/file/d/1ULUzF9 ... sp=sharing

.sav
https://drive.google.com/file/d/1Sy3YfZ ... sp=sharing

(edit added .sav file for users without 7z, updated better instructions)
Last edited by rlame on Mar 21 2020, edited 1 time in total.
User avatar
Balthagor
Supreme Ruler
Posts: 20578
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Performance survey.

Post by Balthagor »

If you want a really good test, do both the first day and the total of 10 days divide by 10 for an average speed.

i3-4160T/8GB/Intel HD 4400 - 46sec first day, 6:14 to Sept 6th (37.4sec average)
i7-870/12GB/GT 320 - 29sec first day, 4:09 to Sept 6th (24.9sec average)
i5-650/12GB/Radeon R9-290 - 37 sec first day, 5:42 to Sept 6th (34.2sec average)

Did you do anything in particular to this savegame? Modded in any way?
Chris Latour
BattleGoat Studios
chris@battlegoat.com
GIJoe597
Board Admin
Posts: 2896
Joined: Sep 29 2008
Human: Yes
Contact:

Re: Performance survey.

Post by GIJoe597 »

I have never seen a 7z file and I have nothing to open it with. Perhaps you can upload the actual save file?
rlame
Sergeant
Posts: 15
Joined: Sep 06 2018
Human: Yes

Re: Performance survey.

Post by rlame »

No modifications or trainers used on save file. Pure 9.1.89 version used.

Unpacked file for users without 7-zip
https://drive.google.com/file/d/1Sy3YfZ ... sp=sharing
rlame
Sergeant
Posts: 15
Joined: Sep 06 2018
Human: Yes

Re: Performance survey.

Post by rlame »

From start of save to sept 6th (10 days) 2min 26s = 14,6s / day average.
GIJoe597
Board Admin
Posts: 2896
Joined: Sep 29 2008
Human: Yes
Contact:

Re: Performance survey.

Post by GIJoe597 »

From start to Sep 6th with the following settings;

game resolution 2560 x 1440,
Graphics Resolution HIGH
All messages
Unit path lines
Show grid outside of sight

2m 40s total for 10 days, average of 16s a day.

Using the below settings;
Game resolution 1920 x 1080
Graphics Resolution: LOW
Other three are same.

2m 15s total for 10 days, average of 13.6s


My computer
Win 10 Pro
Intel(R) Core(TM) i7-8700 @ 3.70GHz (up to 4.7GHz) 6 Core(s) 12 Logical Processor(s)
16GB Corsair Vengeance LPX DDR4 3000MHz C15 Desktop
Crucial MX300 525GB 3D NAND SATA 2.5 inch Internal SSD
Intel Optane Memory Module 32GB
EVGA CLC 280 Liquid/Water CPU Cooler, RGB LED Cooling 400-HY-CL28-V1
EVGA GeForce GTX 1080 Ti FTW3
HDD: WD Gold 4TB Enterprise Class Hard Disk Drive - 7200 RPM Class SATA 6 Gb/s 128MB Cache 3.5 Inch - WD4002FYYZ
rlame
Sergeant
Posts: 15
Joined: Sep 06 2018
Human: Yes

Re: Performance survey.

Post by rlame »

Regarding performance, how many threads does this game support?
When I go (trump rising 2018 -> 2033) it starts to take over 30s /day.
From resource monitor I see this game processor usage is 6% while having some spikes up to 39% (8c/16t 2700x)
User avatar
Balthagor
Supreme Ruler
Posts: 20578
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Performance survey.

Post by Balthagor »

George has answered that before in a thread. IIRC there are 3 primary +1 per region. They double up when there aren't enough threads. There might be some other small ones (sounds, cursors).
Chris Latour
BattleGoat Studios
chris@battlegoat.com
evildari
Brigadier Gen.
Posts: 524
Joined: Aug 10 2017
Human: Yes

Re: Performance survey.

Post by evildari »

i7-950@3.07GHz/16GB/GTX 1080 - 29sec first day, 4:25 to start of Sept 6th (26.5sec average)
3440x1440 Graphics Resolution HIGH, everything else rather off, including music / sounds
my mods
http://www.bgforums.com/forums/viewtopi ... 79&t=25932 (even techs and units for everyone - AI will own you too)
http://www.bgforums.com/forums/viewtopi ... 79&t=29326 (MARSX2)
YoMomma
Brigadier Gen.
Posts: 768
Joined: Jun 27 2015
Human: Yes
Contact:

Re: Performance survey.

Post by YoMomma »

I5 4460 3.2GHZ, 16GB RAM
1st day 1 minute 50 seconds
september 3 11 minutes and 10 seconds (cant continue its like watching paint dry)
[Edit by Moderator: Average 1:35sec/day]
Gameplay 1st
User avatar
Balthagor
Supreme Ruler
Posts: 20578
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Performance survey.

Post by Balthagor »

bump - curious for more submissions on this thread :)

Re-Bump
Chris Latour
BattleGoat Studios
chris@battlegoat.com
ender02
Private
Posts: 1
Joined: Oct 13 2018
Human: Yes

Re: Performance survey.

Post by ender02 »

Hi, I think this is a good thread, so here my test :)

10 days in 2:35 --> 15,5s / day
Processor: i5 6500 @3.2GHz (4 core)
RAM: 16GB on 2000Mhz
Game loaded from HDD, windows 10 on SSD

Regards
arakan94
Lieutenant
Posts: 56
Joined: Oct 10 2018
Human: Yes

Re: Performance survey.

Post by arakan94 »

Ryzen 5 1600, 3.3 GHz
16 GB DDR4 2933 MHz
Widnows 10 on HDD, Game on SSD

Game setting: High, FullHD, 3D terrain on

1st day - 21.6s
10 day average - 16.2s
Kristijonas
Brigadier Gen.
Posts: 878
Joined: Nov 11 2011
Human: Yes

Re: Performance survey.

Post by Kristijonas »

Should it even be full speed?
Camera moved at all from the beginning position?

I ran the given savegame at full speed without moving camera and the results:
1st day: 30 seconds
10 day average: 22 seconds

FPS was mostly stuck at 42 for some reason. sometimes plunged shortly to ~20.

i5 2500
Sapphire Nitro+ (slightly OCd) Rx 470 8gb
dual channel RAM 4+4Gb running at 1333mhz CL7.
full hd

For me the speed seemed slower than average of what I see. Maybe it's because it's in 2026.

Also I tweaked Radeon settings a lot and no matter what I did the speed of days passing as well as FPS is the same. I assume the CPU is the bottleneck.

speaking of which, why is there an FPS cap at 42? Why does it plunge to lower than 42 even when just moving around the map? I'm pretty sure rx 470 is enough to run these graphics at 144hz... Quite annoying when it lags for no apparent reason.

Edit:
In-game settings:
Image

Tests ran on game version 9.1.249.
Windows 10 Build 15063.447 (1703) not updated since early 2017. CPU vulnerabilities are not mitigated in this build. Not sure if that helps the performance any.
Hope this helps!
I am satisfied with the game speed, except for the low FPS and camera lag when looking around the map even with the game paused (it screams unoptimized)
arakan94
Lieutenant
Posts: 56
Joined: Oct 10 2018
Human: Yes

Re: Performance survey.

Post by arakan94 »

Kristijonas wrote:
Dec 15 2019
I'm pretty sure rx 470 is enough to run these graphics at 144hz
Apparently not. It's probably problem with draw calls being CPU intensive an limited by it.

When I have units enabled and some overlay active, I get 4 FPS at max zoom out with my RX 580 while paused. When I disable units and overlays, I get to about 22 FPS.
Post Reply

Return to “General Discussion - SRUltimate”