Asset manager does not read decimals

Place bug reports / questions here.

Moderators: Legend, Balthagor, Moderators

Post Reply
Message
Author
Nerei
Brigadier Gen.
Posts: 988
Joined: Jan 11 2016
Human: Yes

Asset manager does not read decimals

#1 Post by Nerei » Jan 11 2019

Basically the tool ignores any periods in values treating them as integers.

The weight of say the BF-109G is 2.68 if you open default.unit in a text editor but when viewed in the asset manager it is 268.
It is not just a display issue either. If you export the file the weight of the BF-109G will now be 268.

If you load say default.picnums and look at meshscale you will also notice that they are all displayed as integers while in reality they are mostly decimal numbers below 1.

User avatar
Balthagor
Supreme Ruler
Posts: 20239
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Asset manager does not read decimals

#2 Post by Balthagor » Jan 11 2019

k, we'll take a look. ticket 22610.
Chris Latour
BattleGoat Studios
chris@battlegoat.com

Nerei
Brigadier Gen.
Posts: 988
Joined: Jan 11 2016
Human: Yes

Re: Asset manager does not read decimals

#3 Post by Nerei » Mar 06 2019

I decided to experiment a bit and to the best I can find the tool goes by the default regional formats settings in Windows.
Mine was set to use comma (,) for decimal separator and not period (.). Changing it appears to have made it work properly.

I have no problems making this change. I actually thought my computer was already set that way which made it take a bit of time to locate the issue.

However commas as decimal separator is default in a lot of places including continental Europe and Russia so forcing the tool to use periods instead of windows default is probably a good ideas as I doubt you will manage to convince them all to change.

Post Reply

Return to “Issues and Support”