Bug Report: Overflow in message subsystem

Place bug reports / questions here.

Moderators: Legend, Balthagor, Moderators

Post Reply
Message
Author
User avatar
SixthtySixthSix
Warrant Officer
Posts: 46
Joined: Jan 12 2009

Bug Report: Overflow in message subsystem

#1 Post by SixthtySixthSix » Apr 17 2018

Load the file...

Welcome to Russia setup for SRGW mod for SRU...

I have placed many industrial complexes and city builds, all paused, on the map. Over 9000! No... only over 2500...

NOT A BUG, BUT A RENDER PROBLEM HERE- the list on the left showing $ (ECONOMY) build messages reports 450 or so build messages. THIS IS INCORRECT. (Over 9000! No... only over 2500...) However, the bug happens later.

THE BUG
1)- run the game on fast up till july 31 when the war starts ----> so the messages in other groups fill up some.
2)- hover, put cursor over the $ (ECONOMY) and then slide across to the delete all messages and delete them
3)- move down 1 tab to the WORLD EVENTS message button and hover. click the pop-up 'Delete All Messages'
4)- ONE OF THE MESSAGES SHOULD START TO STICK IN THE QUEUE THERE, even though you reclick the clear all messages.

working on my system... lemme know...

-99999f- PCB_Photoetch_93.SAV

User avatar
Balthagor
Supreme Ruler
Posts: 19952
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Bug Report: Overflow in message subsystem

#2 Post by Balthagor » Apr 24 2018

Have you seen this happen outside of your mod? There is no support for mods. We need an example of this happening in the vanilla game.
Chris Latour
BattleGoat Studios
chris@battlegoat.com

User avatar
SixthtySixthSix
Warrant Officer
Posts: 46
Joined: Jan 12 2009

Re: Bug Report: Overflow in message subsystem

#3 Post by SixthtySixthSix » Jun 20 2018

Balthagor wrote:
Apr 24 2018
Have you seen this happen outside of your mod? There is no support for mods. We need an example of this happening in the vanilla game.
no mods installed.
this IS vanilla... it is in SRU:1914. it does the same thing in SRU
i have no mods installed.

the save is from a sandbox game of 1914, i think... i played russia. i was setting up the country's infrastructure, building facilities and such...

if you build over 1000 facilities while the game is paused, the message system incorrectly reports the number of messages...

and freaks out, too. the behavior exhibited indicates a bug/glitch. attempting to clear all of the messages will not clear them all, AND the remaining mesage have to be deleted individually, manually.
Your mouse has moved. The system has to be updated for the changes to take effect. Restart now?

User avatar
SixthtySixthSix
Warrant Officer
Posts: 46
Joined: Jan 12 2009

Re: Bug Report: Overflow in message subsystem

#4 Post by SixthtySixthSix » Jun 26 2018

bump bump

i have replicated the error in SRU global crisis

after building 1000+ facilities (paused) at game start to set up russia, the messge system reports only the low 3 digits of the number of messages... i.e.- there should be 2500 (or so) 'New Construction Started' messages in the message queue, but it only reports 143... after it reported 999 it rolled over.

if i try the 'clear all messages in this category button', it will freak out and leave some messages.
Your mouse has moved. The system has to be updated for the changes to take effect. Restart now?

User avatar
Balthagor
Supreme Ruler
Posts: 19952
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Bug Report: Overflow in message subsystem

#5 Post by Balthagor » Jun 26 2018

Noted.
22021
Chris Latour
BattleGoat Studios
chris@battlegoat.com

DuSean
BattleGoat Team
Posts: 15
Joined: Apr 17 2018
Human: Yes

Re: Bug Report: Overflow in message subsystem

#6 Post by DuSean » Jun 28 2018

Hello SixthtySixthSix,

In regards to this issue you've encountered, I require some specifics. How many facilities did you build prior to starting the game? What kind of facilities were they? I had queued up over 1000 facilites, about 1175 as Russia and did only receive 193 "Construction Began" messages. However, with that many facilities construction would not begin on all of them at once which would explain why you didn't receive the notifications for all of them. I did not notice any "freaking out" when I cleared the messages, so some specifics here would be helpful as well. Look forward to hearing from you, thanks! :)
" 'You miss 100% of the shots you don't take.' - Wayne Gretzky" - Michael Scott

User avatar
SixthtySixthSix
Warrant Officer
Posts: 46
Joined: Jan 12 2009

Re: Bug Report: Overflow in message subsystem

#7 Post by SixthtySixthSix » Jun 29 2018


in the russian save above, there are over 2000 facility constructions started and paused
EDIT: wow... i just reloaded this save in my SRU and it is not exhibiting the all clear bug

EDIT- it may be that the load mechanism clears the bugged state?



the save above has all of that.

around 2500 facilities of all different sorts.

EDIT (no)- the save above should also exhibit the 'Clear Messages' bug.
EDIT (no)- load the save, (i think you have to) run the clock several days ahead

the clear all messages bug should exhibit itself when you try to clear all of the messages in the $ category- there should be messages left after hitting the clear button. EDIT- I have seen this happen, but cannot say the savegame i have forwarded will help exhibit this. drats.
Your mouse has moved. The system has to be updated for the changes to take effect. Restart now?

Post Reply

Return to “Issues and Support”