Issues with Campaign settings

Place bug reports / questions here.

Moderators: Balthagor, Legend, Moderators

Post Reply
Message
Author
Athene
Lieutenant
Posts: 50
Joined: Aug 23 2011
Human: Yes
Location: Italy

Issues with Campaign settings

#1 Post by Athene » Feb 09 2017

Hello,

I haven't played the game in a long time, today I decided to update the game and wanted to start a new campaign to see if issues I previously had with the campaign events and objectives not working properly had been fixed during this time. My problem is, no matter what I set my game settings in the campaign / country selection screen, when I hit start and the get into the game all the settings I have changed are restored to default. Now a few of them can be changed by hitting ctrl+shift+s, but most like "diplomatic merchant marine", "loyalty effects on production" and "weather system" which I don't really like cannot be disabled from this menu. Is this intentional or a bug? Is there any way to fix this and be able to change all the settings for the campaign?

In the sandbox mode the settings work fine, so I have this issue only in the campaign mode. My game version is 9.0.75 and I have already tried verifying the integrity of game files in steam.

User avatar
Balthagor
Supreme Ruler
Posts: 20802
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Issues with Campaign settings

#2 Post by Balthagor » Feb 09 2017

Confirmed, I'll pass it along to the dev team.
21340
Chris Latour
BattleGoat Studios
chris@battlegoat.com

User avatar
Balthagor
Supreme Ruler
Posts: 20802
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Issues with Campaign settings

#3 Post by Balthagor » Jul 06 2017

I'll ask about this again...
Chris Latour
BattleGoat Studios
chris@battlegoat.com

Dr.DoomAD
Private
Posts: 1
Joined: Oct 11 2017
Human: Yes

Re: Issues with Campaign settings

#4 Post by Dr.DoomAD » Oct 11 2017

I have the same problem my version is 9.1.38 will there be a fix on this ?

User avatar
Balthagor
Supreme Ruler
Posts: 20802
Joined: Jun 04 2002
Human: Yes
Location: BattleGoat Studios

Re: Issues with Campaign settings

#5 Post by Balthagor » Oct 11 2017

It remains high on my priority list.
Chris Latour
BattleGoat Studios
chris@battlegoat.com

Athene
Lieutenant
Posts: 50
Joined: Aug 23 2011
Human: Yes
Location: Italy

Re: Issues with Campaign settings

#6 Post by Athene » May 13 2018

I can't believe that after over a year from being reported this bug has not been fixed yet. I have never seen something so elementary as setting / options not working in over 15 years of gaming and hundreds of titles played. I don't have much hope to ever see it fixed at this point judging by the last post about the team refocusing on a new game. Oh well.

Post Reply

Return to “Issues and Support”