Wanna play it but Game performance (lag)

For general talk about Supreme Ruler 2010

Moderators: Balthagor, Legend, Moderators

Post Reply
Message
Author
gouldjg
Captain
Posts: 123
Joined: Jun 28 2008

Wanna play it but Game performance (lag)

#1 Post by gouldjg » Jul 05 2008

Ok maybe this should go in the support thread but I am guessing not many read that thread right now so here goes.

After buying 2020 I went and bought 2010 whilst waiting for the patches as I believe this is a good game also.

Problem is the lag on the map, = very very slow.

Any possible hint to fixes for this e.g. links to past discussions etc

Thanks in advance

User avatar
sirveri
Colonel
Posts: 390
Joined: Jun 12 2008
Location: CA, USA

#2 Post by sirveri » Jul 05 2008

Once the World goes to war you're pretty much screwed. Just take everyone over and the lag will resolve!
- Dave
---------------------
Will mod for food!

SGTscuba
General
Posts: 1780
Joined: Dec 08 2007
Location: Tipton, UK

Re: Wanna play it but Game performance (lag)

#3 Post by SGTscuba » Jul 17 2008

SR lag can be reduced or even eliminated by either playing on smaller maps or by lowering the graphics. I did this because I play world war 3 online with my mate a lot and it lags once we have taken Europe as he just builds a huge suicide army of light infantry.
My SR:U Model Project, get the latest and post suggestions here:

http://www.bgforums.com/forums/viewtopi ... 79&t=28040

User avatar
Legend
General
Posts: 2616
Joined: Sep 08 2002
Human: Yes
Location: Ancaster, Ontario - BattleGoat Studios
Contact:

Re: Wanna play it but Game performance (lag)

#4 Post by Legend » Jul 17 2008

Trying some of the graphic options will help. Also a if you turn on one filter at a time it helps.

gouldjg
Captain
Posts: 123
Joined: Jun 28 2008

Re: Wanna play it but Game performance (lag)

#5 Post by gouldjg » Jul 18 2008

Solved,

Had to get a driver remover program on it as it had residual effects.

Works like a charm now

SGTscuba
General
Posts: 1780
Joined: Dec 08 2007
Location: Tipton, UK

Re: Wanna play it but Game performance (lag)

#6 Post by SGTscuba » Jul 21 2008

glad we were of assistance.
My SR:U Model Project, get the latest and post suggestions here:

http://www.bgforums.com/forums/viewtopi ... 79&t=28040

User avatar
Legend
General
Posts: 2616
Joined: Sep 08 2002
Human: Yes
Location: Ancaster, Ontario - BattleGoat Studios
Contact:

Re: Wanna play it but Game performance (lag)

#7 Post by Legend » Jul 21 2008

Which driver was it? Sound/Video?

gouldjg
Captain
Posts: 123
Joined: Jun 28 2008

Re: Wanna play it but Game performance (lag)

#8 Post by gouldjg » Jul 22 2008

I removed my drivers via uninstall and let windows vista install its default version of my video card.

This made 2010 play great.

Since then I recently downloaded the latest Geforce drivers for my card and 2010 gone srewy again but all other games run great.

Strange but true

Geforce 7500LE is my card.

Any ideas?

SGTscuba
General
Posts: 1780
Joined: Dec 08 2007
Location: Tipton, UK

Re: Wanna play it but Game performance (lag)

#9 Post by SGTscuba » Jul 22 2008

your cards new drivers might be tooooo good for your game, i suffered the same problem when I upgraded my xp to the sp2 standard. Most of the games that didn't work before worked and most that did work before no longer worked.

Its just the fact that your comp might be too good for the game, just like the ms dos probs i had.

:wink:
My SR:U Model Project, get the latest and post suggestions here:

http://www.bgforums.com/forums/viewtopi ... 79&t=28040

Post Reply

Return to “General Discussion”